C'est la fin du projet CSSActif, vous trouverez les explications ici : Fin de CSSActif, ouverture du forum. Le forum reste cependant ouvert à tous et ses ressources sont entièrement disponibles. Merci à tous !
Derniers sujets
» Effet pour vos catégories
Mar 17 Juil 2018, 20:09 par vaaléeriiee

» Qui Est En Ligne - Utopia
Ven 06 Juil 2018, 23:20 par Vincent

» [RPG] Fiche personnage avec bannière latérale
Ven 29 Juin 2018, 06:27 par Tink

» [phpBB2] Sauvegarde des posts en cours d'écriture
Mar 26 Juin 2018, 02:30 par Laluna

» Apparition progressive du corps du forum
Dim 24 Juin 2018, 10:05 par Jimmy

» Formulaire de connexion rapide amélioré
Dim 24 Juin 2018, 10:03 par Jimmy

» Previsualiser le premier message d'un sujet
Dim 24 Juin 2018, 09:57 par Jimmy

» Trois colonnes avec effet Zoom
Mer 20 Juin 2018, 06:58 par Backflip


Partagez | 
 

Problème visuel dans la page d'envoi de message [résolu]

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Voir le profil de l'utilisateur http://walkonvanityruins.forumactif.org/
avatar
{ Membre }
{ Membre }

Féminin Messages : 9



Bonjour   ,
alors pour que je poste une question, il faut vraiment que je sois désespérée, ce qui est le cas xDD

Mon problème réside dans l'action de poster un message : le tableau d'envoi de message est trop long et déforme le fond de page :
» Adresse en hide :

» Screen + ciblage du problème


- Mon forum est en 700 de largeur
- Je code sur Chrome (je sais pas si c'est important mais dans le doute xD)
- Toutes les modifications de Template "Poster & Messages Privés" ont été supprimées (parce que j'ai quand même cherché toute seule pour modifier la taille du tableau, mais rien à faire, ça bouge pas >.<)
- J'ai modifié l'éditeur de texte via le CSS (code ci dessous), mais même en mettant genre "300px" pour la taille, le tableau ne bouge pas.
Code:
/***********************************************APPARENCE NOUVEL EDITEUR*/

.sceditor-container.ltr.sourceMode{background-color :white;border: none !important;}
div.sceditor-toolbar{
background-color :white !important; /*couleur autour des boutons*/
border: none !important;
}

.sceditor-container iframe, .sceditor-container textarea {
background-color: white!important; /*couleur de la zone d'ecriture*/
color: #464646 !important;
border: 1px solid #9e0c0c!important;
-x-system-font:none;
font-size:11px !important;
font-size-adjust:none;
font-stretch:normal;
font-style:normal;
font-variant:normal;
font-weight:normal;
line-height:11px;
margin:0px!important;
padding:5px !important;
text-align:justify !important;
width:auto;!important;
height : 240px !important;}
        
div.sceditor-group
        {
          background-color: white !important;
          color: white !important;
          border-top: 1px solid #9e0c0c!important;
          border-bottom: 1px solid #9e0c0c!important;
          border-left: 0px;
          border-right: 0px;
          margin:0px!important;
          margin-bottom:3px!important;
          background-color: #e9e9e9 !important;
        }
    
a.sceditor-button.hover {background-color: white !important;}
.sceditor-button-headers{display:none!important;}

#sceditor_smilies ,#sce_smilies_body .row1 , #sce_smilies_body {background:white; max-width: 200px !important;
margin: 0px!important; padding:0px!important;}
#sceditor_smilies {border: 1px solid #9e0c0c; margin: 0px!important; padding:0px!important;}

 
/*********************************************FIN APPARENCE NOUVEL EDITEUR*/

J'espère avoir donné toutes les infos importantes =/
Merci d'avance de votre attention


Dernière édition par YumikoSayaka le Ven 02 Jan 2015, 09:47, édité 1 fois
MessageSujet: Problème visuel dans la page d'envoi de message [résolu]   Jeu 01 Jan 2015, 10:59
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
avatar
{ Modérateur }
{ Modérateur }

Messages : 1216



Hello Yumiko Smile

Bonne année !

Pourrais tu ouvrir un forum aux invités où l'on pourrait poster dessus s'il te plait (pour voir le problème directement) Smile ?


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Problème visuel dans la page d'envoi de message [résolu]   Jeu 01 Jan 2015, 17:20
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://walkonvanityruins.forumactif.org/
avatar
{ Membre }
{ Membre }

Féminin Messages : 9



Bonsoir !
Ouiii merci ! Bonne année à toi aussi *o*

J'ai ouvert le premier forum "votre 1er forum" =)
Merci de bien vouloir jeter un coup d’œil à cette page troll
MessageSujet: Re: Problème visuel dans la page d'envoi de message [résolu]   Jeu 01 Jan 2015, 19:28
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
avatar
{ Modérateur }
{ Modérateur }

Messages : 1216



Hello Yumiko Smile

Il me semble que le problème vient de la largeur du sujet du message Smile
Normalement la largeur du textarea est calculée en js par rapport à la largeur déjà présente sur ton forum (je crois).

Dans ton template posting_body normalement il y a ceci :

Code:
<input class="post" style="width:450px" type="text" name="subject" value="{SUBJECT}" size="45" maxlength="{TOPIC_TITLE_MAXLENGTH}" tabindex="2" title="{TOPIC_TITLE_LENGTH_EXPLAIN}" onkeypress="if (event.keyCode==13){return false}" />

Ce qui nous intéresse est le CSS mis pour sa taille : style="width:450px"
450px est trop large pour ton forum, tu peux donc diminuer cette valeur comme tu le souhaites (par exemple 400px), ou bien tu peux mettre "100%" à la place de "450px", comme ça le sujet prendra toute la place disponible.

Dis nous si avec cette modification c'est mieux Smile ?


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Problème visuel dans la page d'envoi de message [résolu]   Ven 02 Jan 2015, 08:46
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://walkonvanityruins.forumactif.org/
avatar
{ Membre }
{ Membre }

Féminin Messages : 9



Han j'avais pas vu ça T.T

C'était bien là le problème, c'est réglé ! Merci beaucoup pour ton aide
MessageSujet: Re: Problème visuel dans la page d'envoi de message [résolu]   Ven 02 Jan 2015, 09:47
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
avatar
{ Modérateur }
{ Modérateur }

Messages : 1216



Super, contente d'avoir pu t'aider Smile

Je lock et j'archive.


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Problème visuel dans la page d'envoi de message [résolu]   Ven 02 Jan 2015, 13:01
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: Problème visuel dans la page d'envoi de message [résolu]   
Revenir en haut Aller en bas
 

Problème visuel dans la page d'envoi de message [résolu]

Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

 Sujets similaires

-
» Détecter des liens dans une page web [RESOLU]
» Un powerpoint dans une page web
» lien vers page php
» Problème envoi/réception SMS MMS!
» [résolu]probléme de lenteur et page de pub intenpestive !!!!

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
CSSActif :: De la théorie à la pratique :: Aide CSS & xHTML :: Problèmes résolus-

Partenaires Or


← Page précédente   ↑ Aller en haut Copyright © CSSActif 2009 - 2013 Tous droits réservés
Créer un forum | © phpBB | Forum gratuit d'entraide | Contact | Signaler un abus | Forum gratuit