C'est la fin du projet CSSActif, vous trouverez les explications ici : Fin de CSSActif, ouverture du forum. Le forum reste cependant ouvert à tous et ses ressources sont entièrement disponibles. Merci à tous !
Derniers sujets
» Vos partenaires dans le footer
Sam 10 Nov 2018, 09:39 par FredR

» Mettre votre © Copyright dans le footer de votre forum
Sam 10 Nov 2018, 09:25 par FredR

» Effet pour vos sous-forums
Sam 10 Nov 2018, 06:13 par FredR

» Pour faire des beaux titres de sous-forums
Sam 10 Nov 2018, 05:55 par FredR

» Bouton ''Sélectionner le contenu'', pour les codes
Sam 10 Nov 2018, 05:41 par FredR

» Modifier l'apparence du titre des topics
Sam 10 Nov 2018, 05:28 par FredR

» Début d'un sujet/Fond pour sujet important
Sam 10 Nov 2018, 02:45 par FredR

» Previsualiser le premier message d'un sujet
Ven 09 Nov 2018, 12:49 par FredR


Partagez | 
 

Problème de balises qui se glissent dans l'apparence du forum [Résolu]

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Voir le profil de l'utilisateur http://ohdarling.free.fr
avatar
{ Membre }
{ Membre }

Féminin Messages : 8



Bonjour,

Alors voilà, je bidouille mon forum de test pour changer l'apparence des forums et catégories. J'me lance donc dans les templates. Seulement voilà, y'a un soucis.
Désormais, lorsqu'on survole les sous-forums, y'a des balises qui se glissent dans les descriptions alors qu'elles sont inexistantes.
Spoiler:
 
J'ignore d'où ça sort. Si c'est en rapport avec le template ou autre. Aussi, après plusieurs heures à m'énerver sur mon ordi, je viens demander votre aide, si vous avez une idée de l'origine de ce bug.
Merci d'avance.  

Edit : l'adresse de mon forum de test http://ohdarling.forumactif.org/
et le template :
Code:
<link href='http://fonts.googleapis.com/css?family=Dorsa' rel='stylesheet' type='text/css'>
<link href='http://fonts.googleapis.com/css?family=News+Cycle' rel='stylesheet' type='text/css'>

<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
   <tr><td valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall">{LAST_VISIT_DATE}<br>{CURRENT_TIME}<br></span>
         <!-- END switch_user_logged_in -->
         <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br>
         <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br>
         <!-- END switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
   </td></tr>
</table>

<!-- BEGIN catrow --><!-- BEGIN tablehead -->
<div style="width: 100%; height: 50px;background-image: url('http://ohdarling.free.fr/Images/mf/hautcat.png');" class="secondarytitle">
   <div style="text-align:center;padding-top:20px">{catrow.tablehead.L_FORUM}</div>
</div>
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
<!-- END tablehead -->
    <!-- BEGIN cathead -->
    <tr><td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="800">
         <h{catrow.cathead.LEVEL} class="hierarchy">
         <span class="cattitle"><a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a></span>
         </h{catrow.cathead.LEVEL}>
        </td>
        <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right"> </td>
    </tr>
<!-- END cathead -->
<!-- BEGIN forumrow -->
    <tr>
    <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="40"><img src="{SPACER}" height="0" width="40" alt="." /></td>
    <!-- END inc -->
        
        <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="75%" height="50">
         <h{catrow.forumrow.LEVEL} class="hierarchy">
         <span class="forumlink"><a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br></span>
         </h{catrow.forumrow.LEVEL}>
                          
         <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
         <!-- END switch_moderators_links -->
            {catrow.forumrow.L_LINKS}
         <!-- Navigation rapide -->
            <table><tr><td width="130px" valign="top" class="arrondi"><div class="i" style="text-align:center;padding:4px">NAVIGATION RAPIDE</div>
            <div style="overflow:auto; height:80px"><span class="gensmall" id="subforums">
            <div class="sousforum">{catrow.forumrow.LINKS}</div></span>
            <script type="text/javascript"> jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,'<br />')).removeAttr('id'); </script>
            </div></td>
         <!-- fin navigation rapide -->
            <td><span class="gensmall"><div class="milieu">{catrow.forumrow.FORUM_DESC}</div></span></td>
            </tr></table>                                      
      </td>
       <!-- image sujet -->
      <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="bottom" width="50px">
         <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" style="margin-left:-25px;padding-bottom:2px;padding-right:4px" />
      </td>
        <!-- fin image sujet -->
        
        <!-- dernier message -->
        <td class="row3 over" align="center" valign="middle" width="25%" height="50">
            <span class="gensmall"></span><br>
            <div style="margin-top:-10px">
            <div class="i" style="padding-bottom:4px">DERNIER MESSAGE</div>
            <span class="gensmall"><div class="arrondi">{catrow.forumrow.LAST_POST}</div></span><br><div class ="separateur"></div><br>
            <span class="gensmall"><div class="arrondi"><div class="i">{catrow.forumrow.POSTS} MESSAGES - {catrow.forumrow.TOPICS} TOPICS</div></div></span>
            </div>
        </td>
    </tr>
        <!-- fin dernier message -->
            
        <!-- END forumrow -->
        <!-- BEGIN catfoot -->
    <tr>
        <!-- BEGIN inc -->
        <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
        <!-- END inc -->
        <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
    </tr><br>
        <!-- END catfoot --><!-- BEGIN tablefoot -->
</table>
<div style="width: 100%; height: 25px;background-color:#F3F3F3;text-align: center;font-size: 25px;font-family:Dorsa; font-weight:normal !important;
letter-spacing: 5px;line-height: 25px;text-shadow: 1px 1px 0 #ffFFff; color:#D7CED6;" >MODERN FAMILY</div><br>
      <!-- END tablefoot --><!-- END catrow -->


Dernière édition par Ashou le Ven 22 Aoû 2014, 17:11, édité 1 fois
MessageSujet: Problème de balises qui se glissent dans l'apparence du forum [Résolu]   Ven 22 Aoû 2014, 13:43
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
avatar
{ Modérateur }
{ Modérateur }

Messages : 1216



Les descriptions des sous forums sont dans le code généré par forumactif pour les liens vers les sous forums ^____^
Les balises sont dans la description du sous forum normalement Wink

EDIT : j'avais mal compris ^^'
Ca vient du code de remplacement, qui change les virgules en retour à la ligne
Code:
jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,'<br />')).removeAttr('id');

Tu peux enlever ce code et ajouter ceci dans le CSS :
Code:
.sousforum {
    font-size: 0; /* on masque les virgules avec une taille de 0 */
}

.sousforum a {
    display: block;
    font-size: 13px; /* ta taille de police */
}


Présence réduite, mais je reste disponible, il faut juste être patient ♥


Dernière édition par Nihil le Ven 22 Aoû 2014, 17:07, édité 2 fois
MessageSujet: Re: Problème de balises qui se glissent dans l'apparence du forum [Résolu]   Ven 22 Aoû 2014, 17:00
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://ohdarling.free.fr
avatar
{ Membre }
{ Membre }

Féminin Messages : 8



J'aimerais que ce soit aussi simple, j'y ai pensé surtout, mais non.   

Quand je vais vérifier le sous-forum, tout ce que je lis c'est
Code:
<div style="text-align: justify;padding:4px;font-family: Arial; font-size: 10px;">
   <strong>MF</strong> ✿ Le seul, l'unique. Parce qu'on l'aime, parce qu'on le bichonne. Parce qu'on veut le rendre beau ma charie.
</div>
Sans les balises mystérieuses ^^

P.S. : ne pas faire attention au texte ô combien intelligent haha, c'est juste pour remplir et donc avoir une idée du rendu



Dernière édition par Ashou le Ven 22 Aoû 2014, 17:07, édité 2 fois
MessageSujet: Re: Problème de balises qui se glissent dans l'apparence du forum [Résolu]   Ven 22 Aoû 2014, 17:05
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
avatar
{ Modérateur }
{ Modérateur }

Messages : 1216



Je viens d'éditer mon précédent message, dis moi si cela fonctionne Very Happy


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Problème de balises qui se glissent dans l'apparence du forum [Résolu]   Ven 22 Aoû 2014, 17:06
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://ohdarling.free.fr
avatar
{ Membre }
{ Membre }

Féminin Messages : 8



Ça fonctionne ! Magnifique, merci beaucoup  cheers  
MessageSujet: Re: Problème de balises qui se glissent dans l'apparence du forum [Résolu]   Ven 22 Aoû 2014, 17:11
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
avatar
{ Modérateur }
{ Modérateur }

Messages : 1216



Contente d'avoir pu t'aider Very Happy
Si tu as ouvert une demande d'aide sur d'autres forum, pense à les mettre en résolu là bas aussi pour éviter que des gens cherchent alors que c'est bon :p !
Bon courage pour ton forum   


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Problème de balises qui se glissent dans l'apparence du forum [Résolu]   Ven 22 Aoû 2014, 17:12
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://ohdarling.free.fr
avatar
{ Membre }
{ Membre }

Féminin Messages : 8



Je l'ai fait, je leur ai même expliqué que ça venait du script, comme ça, si ça arrive à quelqu'un d'autre et qu'il fait la recherche, il trouvera son bonheur Wink
Encore merci.
MessageSujet: Re: Problème de balises qui se glissent dans l'apparence du forum [Résolu]   Ven 22 Aoû 2014, 17:28
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: Problème de balises qui se glissent dans l'apparence du forum [Résolu]   
Revenir en haut Aller en bas
 

Problème de balises qui se glissent dans l'apparence du forum [Résolu]

Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

 Sujets similaires

-
» Problème avec les mêmes messages en double dans un forum
» Désolé, mais seuls les utilisateurs avec un accès spécial peuvent lire des sujets dans ce forum
» Accès impossible à "nouveau et répondre" dans le forum
» Mettre une bannière dans un forum
» Code insérer colonne derniers messages dans sous forum

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
CSSActif :: De la théorie à la pratique :: Aide CSS & xHTML :: Problèmes résolus-

Partenaires Or


← Page précédente   ↑ Aller en haut Copyright © CSSActif 2009 - 2013 Tous droits réservés
Créer un forum | © phpBB | Forum gratuit d'entraide | Contact | Signaler un abus | Forum gratuit