Question sous forum Bouton_activeQuestion sous forum Bouton_hoverQuestion sous forum Fb-hoverQuestion sous forum Fb-active
C'est la fin du projet CSSActif, vous trouverez les explications ici : Fin de CSSActif, ouverture du forum. Le forum reste cependant ouvert à tous et ses ressources sont entièrement disponibles. Merci à tous !
Derniers sujets
» [Plugin] Interagir avec le clavier de l'utilisateur
Question sous forum EmptyJeu 11 Juil 2019, 12:09 par Spleen

» [phpBB2] Sauvegarde des posts en cours d'écriture
Question sous forum EmptyJeu 11 Juil 2019, 11:41 par Spleen

» Formulaire de connexion rapide amélioré
Question sous forum EmptyJeu 11 Juil 2019, 11:38 par Spleen

» Modifier le message rapide pour lui donner l'aspect du message étendu
Question sous forum EmptyJeu 11 Juil 2019, 11:35 par Spleen

» Avatar centré dans le profil
Question sous forum EmptyJeu 11 Juil 2019, 11:32 par Spleen

» Trois colonnes avec effet Zoom
Question sous forum EmptyMer 10 Juil 2019, 14:49 par BOTM

» Barre(s) Hitskinienne
Question sous forum EmptyMer 10 Juil 2019, 14:34 par BOTM

» Se débarasser de la "Couleur Cadre Catégorie"
Question sous forum EmptyMer 10 Juil 2019, 14:20 par BOTM


Partagez
 

Question sous forum

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
Bonsoir,

J'aimerais savoir s'il y avait un tuto pour mettre les sous forums en spoiler, car j'ai chercher mais j'ai pas trouvé (je suis pas doué surement), car j'ai trop de sous forums, et c'est vraiment moche, surtout qu'en plus de ça, bien qu'en dessous de la descriptions du forum, ils débordent en longueur, faisant un rendu très moyen. Du coup j'aimerais les mettre en spoiler et on les verrais au passage de la souris.
MessageSujet: Question sous forum   Question sous forum EmptyJeu 24 Oct 2013, 15:36
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Bonsoir Akesato,

Il ne me semble pas avoir de tutoriel ou code tout fait pour cela sur CSSActif.
Si tu me fais un schéma de ce que tu voudrais (car là visuellement c'est flou, il y a pleins de rendus différents possibles), je peux t'aider à faire le code Smile


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyJeu 24 Oct 2013, 15:54
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
Donc c'est normal que je ne l'ai pas trouvé en cherchant, ouf j'avais peur d'être tombé à côté et passer pour une naze ^^"

Alors le schéma ça donnerait quelque chose dans ce genre là :
https://i.servimg.com/u/f57/14/28/12/86/exempl10.jpg
Puis :
https://i.servimg.com/u/f57/14/28/12/86/exempl11.jpg

Pour le forum : strong-world.forumactif.com
Comme on peut le voir dessus ... les sous forums c'est vraiment moche, y'en a trop et ils vont trop loin ><"

En tout cas merci de la réponse =)
MessageSujet: Re: Question sous forum   Question sous forum EmptyJeu 24 Oct 2013, 17:50
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Je sais pas si c'est par ce que je suis en invité et que je vois peut-être pas tout, mais chez moi je trouve que ça va tes sous forums ^^

Je vois que tu as déjà modifié tes template, pourrais tu me donner le code s'il te plait ?

Voici le principe de ce que nous allons faire.
  1. Entourer tous les sous forum dans une div
  2. Cacher cette div à l'état normal
  3. Créer une div avec dedans "Voir les sous forum"
  4. Au survol de cette div "voir les sous forum", on fait apparaitre la div des sous forum.


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyJeu 24 Oct 2013, 18:01
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
En effet on voit pas tout quand on est invité, je vais te montrer ce que ça donne avec ce sceen :

https://i.servimg.com/u/f57/14/28/12/86/bug_bm10.jpg

J'aime bcp l'idée.

Voici le code :
Code:
{JAVASCRIPT}
<!-- BEGIN message_admin_index -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
   <!-- BEGIN message_admin_titre -->
   <tr>
      <td class="catHead" height="28"><span class="cattitle">{message_admin_index.message_admin_titre.MES_TITRE}</span></td>
   </tr>
   <!-- END message_admin_titre -->
   <!-- BEGIN message_admin_txt -->
   <tr>
      <td class="row1" rowspan="3" align="center" valign="middle">
      <div class="gensmall">{message_admin_index.message_admin_txt.MES_TXT}</div>
      </td>
   </tr>
   <!-- END message_admin_txt -->
</table>
<!-- END message_admin_index -->

<!-- BEGIN switch_user_login_form_header -->
<form action="{S_LOGIN_ACTION}" method="post" name="form_login">
   <!-- BEGIN switch_fb_connect_no -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td class="row1" align="center">
            <table border="0" cellspacing="0" cellpadding="0">
               <tr>
                  <td><span class="genmed">{L_USERNAME}:</span> </td>
                  <td><input class="post" type="text" size="10" name="username"/> </td>
                  <td>
                     <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                     <span class="gensmall">{L_AUTO_LOGIN}</span> 
                  </td>
               </tr>

               <tr>
                  <td><span class="genmed">{L_PASSWORD}:</span> </td>
                  <td><input class="post" type="password" size="10" name="password"/> </td>
                  <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect_no -->

   <!-- BEGIN switch_fb_connect -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td valign="top" width="100%"  class="row1" align="center">
            <table width="100%">
               <tr>
                  <td width="55%" valign="middle" align="right">
                     <table class="right">
                        <tr>
                           <td><span class="genmed">{L_USERNAME}:</span> </td>
                           <td><input class="post" type="text" size="10" name="username"/> </td>
                           <td>
                              <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                              <span class="gensmall">{L_AUTO_LOGIN}</span> 
                           </td>
                        </tr>

                        <tr>
                           <td><span class="genmed">{L_PASSWORD}:</span> </td>
                           <td><input class="post" type="password" size="10" name="password"/> </td>
                           <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
                        </tr>
                     </table>
                  </td>
                  <td width="10%" align="center" valign="middle">
                     <span class="genmed fb_or">{switch_user_login_form_header.switch_fb_connect.L_OR}</span>
                  </td>
                  <td width="35%" class="align_gauche"><fb:login-button size="large" onlogin="facebook_login()" v="2" scope="{switch_user_login_form_header.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_header.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect -->
</form>
<!-- END switch_user_login_form_header -->

{CHATBOX_TOP}
{BOARD_INDEX}
<table width="100%" border="0" cellspacing="0" cellpadding="0">
   <tr>
      <td width="50%" valign="top">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall"><a href="{U_MARK_READ}" class="gensmall">{L_MARK_FORUMS_READ}</a>
         <!-- END switch_user_logged_in -->
         <!-- BEGIN switch_delete_cookies -->
         <br /><a href="{switch_delete_cookies.U_DELETE_COOKIES}" class="gensmall">{switch_delete_cookies.L_DELETE_COOKIES}</a>
         <!-- END switch_delete_cookies -->
         </span>
      </td>
      <td width="50%" align="right">
         <span class="gensmall">
            <a href="{U_TODAY_ACTIVE}" class="gensmall">{L_TODAY_ACTIVE}</a><br />
            <a href="{U_TODAY_POSTERS}" class="gensmall">{L_TODAY_POSTERS}</a><br />
            <a href="{U_OVERALL_POSTERS}" class="gensmall">{L_OVERALL_POSTERS}</a>
            <!-- BEGIN switch_on_index -->
               <!-- BEGIN switch_delete_cookies -->
               <br /><a href="{switch_on_index.switch_delete_cookies.U_DELETE_COOKIES}" class="gensmall">{switch_on_index.switch_delete_cookies.L_DELETE_COOKIES}</a>
               <!-- END switch_delete_cookies -->
            <!-- END switch_on_index -->
         </span>
      </td>
   </tr>
</table>

<!-- BEGIN switch_user_login_form_footer -->
<form action="{S_LOGIN_ACTION}" method="post" name="form_login">
   <!-- BEGIN switch_fb_connect_no -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td class="row1" align="center">
            <table border="0" cellspacing="0" cellpadding="0">
               <tr>
                  <td><span class="genmed">{L_USERNAME}:</span> </td>
                  <td><input class="post" type="text" size="10" name="username"/> </td>
                  <td>
                     <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                     <span class="gensmall">{L_AUTO_LOGIN}</span> 
                  </td>
               </tr>

               <tr>
                  <td><span class="genmed">{L_PASSWORD}:</span> </td>
                  <td><input class="post" type="password" size="10" name="password"/> </td>
                  <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect_no -->

   <!-- BEGIN switch_fb_connect -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td valign="top" width="100%"  class="row1" align="center">
            <table width="100%">
               <tr>
                  <td width="55%" valign="middle">
                     <table class="right">
                        <tr>
                           <td><span class="genmed">{L_USERNAME}:</span> </td>
                           <td><input class="post" type="text" size="10" name="username"/> </td>
                           <td>
                              <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                              <span class="gensmall">{L_AUTO_LOGIN}</span> 
                           </td>
                        </tr>

                        <tr>
                           <td><span class="genmed">{L_PASSWORD}:</span> </td>
                           <td><input class="post" type="password" size="10" name="password"/> </td>
                           <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
                        </tr>
                     </table>
                  </td>
                  <td width="10%" align="center" valign="middle">
                     <span class="genmed fb_or">{switch_user_login_form_footer.switch_fb_connect.L_OR}</span>
                  </td>
                  <td width="35%" class="align_gauche"><fb:login-button size="large" onlogin="facebook_login()" v="2" scope="{switch_user_login_form_footer.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_footer.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect -->
</form>
<!-- END switch_user_login_form_footer -->
MessageSujet: Re: Question sous forum   Question sous forum EmptyDim 27 Oct 2013, 19:38
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Effectivement ça fait beaucoup de sous forum... O___O... Ca serait pas plus simple de trouver un autre agencement ? (pour le confort des utilisateurs ?)

Bon par contre je crois tu ne m'as pas fourni le bon template là Razz.


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyDim 27 Oct 2013, 19:58
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
Bah j'ai pas d'autre idée ><", sur un forum j'avais vu ça :
https://i.servimg.com/u/f57/14/28/12/86/ex_bmp10.jpg
Et je me suis dis que ça serait pas mal pour justement éviter que ça soit moche, vu que les sous forums serait toujours en spoil et ensuite ils seraient tous bien rangé =)

Ah ? O_o celui là ça doit être le bon :
Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
  <tr>
      <td valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <span class="gensmall">{LAST_VISIT_DATE}<br />
        {CURRENT_TIME}<br />
        </span>
        <!-- END switch_user_logged_in -->
        <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
        <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
        <!-- END switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
  </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
  <tr>
      <th colspan="3" nowrap="nowrap" width="100%" class="secondarytitle"> {catrow.tablehead.L_FORUM} </th>
  </tr>
  <!-- END tablehead -->
  <!-- BEGIN cathead -->
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
                          <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
              <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
        </h{catrow.cathead.LEVEL}>
                    </div>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right"> </td>
  </tr>
  <!-- END cathead -->
  <!-- BEGIN forumrow -->
  <tr>
                <td class="tdcatitre" colspan="3" valign="top" width="100%" height="50">
        <h{catrow.forumrow.LEVEL} class="hierarchy">
            <div class="catitre"><span class="forumlink">
              <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
                                  </span></div>
        </h{catrow.forumrow.LEVEL}>
                </td>
  </tr>
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td class="tdimg" align="center" valign="middle">
        <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" class="imgarrondie" />
      </td>
      <td class="tddesc" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
                  <div class="divdesc"><span class="genmed">{catrow.forumrow.FORUM_DESC}</span></div>
      </td>
      <td class="postslien" align="center" valign="middle" height="50">
                  <div class="postsdate">
                    <span class="gensmall">{catrow.forumrow.POSTS} messages | {catrow.forumrow.TOPICS} Sujets<br/>
                      {catrow.forumrow.LAST_POST}</span></div>
      </td>
  </tr>
  <tr>
            <td class="ssliens" valign="top" width="765px" colspan="3">
        <span class="gensmall">
                    <div class="sousfo">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</div>
                          </span>
            </td>
  </tr>
  <!-- END forumrow -->
  <!-- BEGIN catfoot -->
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
  </tr>
  <!-- END catfoot -->
  <!-- BEGIN tablefoot -->
</table>
  <div width="100%" class="img_bas"> <img src="http://i42.servimg.com/u/f42/17/52/04/88/png1010.png"/></div>
  <img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->
MessageSujet: Re: Question sous forum   Question sous forum EmptyMar 29 Oct 2013, 07:58
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Aurais tu un forum test ? En effet, on va le faire petit à petit, et il est possible qu'à des moments le rendu ne soit pas nickel. En plus, avoir le lien avec les bugs ou les problèmes me permet de les régler plus facilement (en effet j'utilise énormément l'outil inspecteur d'élément).

Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
  <tr>
      <td valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <span class="gensmall">{LAST_VISIT_DATE}<br />
        {CURRENT_TIME}<br />
        </span>
        <!-- END switch_user_logged_in -->
        <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
        <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
        <!-- END switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
  </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
  <tr>
      <th colspan="3" nowrap="nowrap" width="100%" class="secondarytitle"> {catrow.tablehead.L_FORUM} </th>
  </tr>
  <!-- END tablehead -->
  <!-- BEGIN cathead -->
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
                          <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
              <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
        </h{catrow.cathead.LEVEL}>
                    </div>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right"> </td>
  </tr>
  <!-- END cathead -->
  <!-- BEGIN forumrow -->
  <tr>
                <td class="tdcatitre" colspan="3" valign="top" width="100%" height="50">
        <h{catrow.forumrow.LEVEL} class="hierarchy">
            <div class="catitre"><span class="forumlink">
              <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
                                  </span></div>
        </h{catrow.forumrow.LEVEL}>
                </td>
  </tr>
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td class="tdimg" align="center" valign="middle">
        <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" class="imgarrondie" />
      </td>
      <td class="tddesc" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%">
                  <div class="divdesc"><span class="genmed">{catrow.forumrow.FORUM_DESC}</span></div>
              <div class="afficher">Voir les sous forums</div>
              <div class="sousfo"><span class="gensmall">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span></div>
      </td>
      <td class="postslien" align="center" valign="middle" height="50">
                  <div class="postsdate">
                    <span class="gensmall">{catrow.forumrow.POSTS} messages | {catrow.forumrow.TOPICS} Sujets<br/>
                      {catrow.forumrow.LAST_POST}</span></div>
      </td>
  </tr>
  <!-- END forumrow -->
  <!-- BEGIN catfoot -->
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
  </tr>
  <!-- END catfoot -->
  <!-- BEGIN tablefoot -->
</table>
  <div width="100%" class="img_bas"> <img src="http://i42.servimg.com/u/f42/17/52/04/88/png1010.png"/></div>
  <img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->
Modification du HTML --> J'ai déplacé l'endroit des sous forum, et j'ai rajouté une div pour "Voir les sous forum". Pour l'instant pas de CSS, c'est juste pour vérifier si ça marche bien ^^


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyMar 29 Oct 2013, 17:29
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
J'en ai bien un =)
Voila du coup ce que ça donne : http://teste-design.forumactif.com/
(voir les sous forums est écrit en noir donc on le voit pas)
MessageSujet: Re: Question sous forum   Question sous forum EmptyJeu 31 Oct 2013, 07:59
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Un peu de CSS pour afficher "Voir les sous forum".
Code:
div.afficher {
  color: white;
  font-size: 12px;
  text-align: right;
}
Ensuite dans le code JS (PA > Module > Javascript), tu mets :
Code:
$function() {
      $('.sousfo').hide(); /* on cache la liste des sous forum */
      $('.afficher').click(function() {
            $(this).next().slideToggle( "slow" );
      });
}
Je suppose que ça devrait marcher ^^


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyVen 01 Nov 2013, 08:21
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
J'ai tout installé mais ça rend pas comme ça devrait :
http://teste-design.forumactif.com/

ps : je suis absente jusqu'à mardi soir.
MessageSujet: Re: Question sous forum   Question sous forum EmptyVen 01 Nov 2013, 18:18
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Hum, il doit y avoir un bug dans le JS...

Est ce que tu l'as bien activé et activé au moins sur l'index ? Si oui, est ce que tu pourrais me communiquer l'URL du code s'il te plait ?

Ne t'inquiète pas pour ton absence, personne ne va venir archiver ton sujet Wink (mais merci de prévenir ^^)


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyVen 01 Nov 2013, 18:40
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
Il est activé, et je l'ai mis sur toutes les pages (dans le doute)
Même en le mettant juste sur l'index ça marche pas =/
http://teste-design.forumactif.com/11656.js
Voila ^^
MessageSujet: Re: Question sous forum   Question sous forum EmptyMar 05 Nov 2013, 14:37
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Essaye en mettant juste :
Code:
$('.sousfo').hide();$('.afficher').click(function(){$(this).next().slideToggle("slow")});


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyMar 05 Nov 2013, 14:55
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
Hélas rien ne change =/
MessageSujet: Re: Question sous forum   Question sous forum EmptyJeu 07 Nov 2013, 07:17
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Je sais pas si c'est normal, mais sur http://teste-design.forumactif.com/11982.js le contenu est toujours l'ancien code.

Là je comprends pas trop le problème... Éventuellement accepterais tu de me communiquer par MP des accès à un compte admin sur le forum test s'il te plait ? Comme ça j'essayerai de comprendre directement sur le forum pour le JS, par ce que là je ne sais pas du tout :s.


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyJeu 07 Nov 2013, 13:43
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
Normalement c'est le nouveau code O_o
http://teste-design.forumactif.com/11628.js
C'est bien ça le nouveau code ?
Si c'est pas ça oui je te passerais tout ça par mp ^^
MessageSujet: Re: Question sous forum   Question sous forum EmptyJeu 07 Nov 2013, 18:18
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Hum là je comprends pas... Il doit y avoir un problème avec peut être les autres JS qui créent un bug ou quelque chose comme ça o__o.

Dernier tentative :
Code:
$(document).ready(function(){$('.sousfo').hide();$('.afficher').click(function(){$(this).next().slideToggle("slow")});});


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyJeu 07 Nov 2013, 18:38
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
http://teste-design.forumactif.com/
ça marche !
Dernière question : on peut faire apparaitre les sous forums non pas en cliquant avec la souris mais à son passage ?
MessageSujet: Re: Question sous forum   Question sous forum EmptyLun 11 Nov 2013, 09:30
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Essaye en remplaçant le "click" par "hover"


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyLun 11 Nov 2013, 11:00
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://strong-world.forumactif.com/
Akesato
{ Membre }
{ Membre }

Masculin Messages : 86



Question sous forum Empty
C'est parfait merci beaucoup =D
♥ ♥ ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyLun 11 Nov 2013, 11:42
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nihil
{ Modérateur }
{ Modérateur }

Messages : 1216



Question sous forum Empty
Contente d'avoir pu t'aider ^^
Pense à éditer le titre de ton sujet pour préciser la mention "Résolu" Smile


Présence réduite, mais je reste disponible, il faut juste être patient ♥
MessageSujet: Re: Question sous forum   Question sous forum EmptyMar 12 Nov 2013, 15:57
Revenir en haut Aller en bas
Contenu sponsorisé




Question sous forum Empty
MessageSujet: Re: Question sous forum   Question sous forum Empty
Revenir en haut Aller en bas
 

Question sous forum

Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

 Sujets similaires

-
» Bannière défilante secondaire dans un(ou plusieurs) sous forum/catégorie
» espace entre sous forum et catégorie
» sous-forum
» Template, mettre les liens des sous forum à droite
» Annuler suppression d'un sous forum

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
CSSActif :: De la théorie à la pratique :: Aide CSS & xHTML :: Problèmes résolus-

Partenaires Or


← Page précédente   ↑ Aller en haut Copyright © CSSActif 2009 - 2013 Tous droits réservés
Créer un forum | © phpBB | Forum gratuit d'entraide | Contact | Signaler un abus | Forumactif.com | Informatique et Internet | Internet