C'est la fin du projet CSSActif, vous trouverez les explications ici : Fin de CSSActif, ouverture du forum. Le forum reste cependant ouvert à tous et ses ressources sont entièrement disponibles. Merci à tous !
Derniers sujets
» Vos partenaires dans le footer
Sam 10 Nov 2018, 09:39 par FredR

» Mettre votre © Copyright dans le footer de votre forum
Sam 10 Nov 2018, 09:25 par FredR

» Effet pour vos sous-forums
Sam 10 Nov 2018, 06:13 par FredR

» Pour faire des beaux titres de sous-forums
Sam 10 Nov 2018, 05:55 par FredR

» Bouton ''Sélectionner le contenu'', pour les codes
Sam 10 Nov 2018, 05:41 par FredR

» Modifier l'apparence du titre des topics
Sam 10 Nov 2018, 05:28 par FredR

» Début d'un sujet/Fond pour sujet important
Sam 10 Nov 2018, 02:45 par FredR

» Previsualiser le premier message d'un sujet
Ven 09 Nov 2018, 12:49 par FredR

Autopassion.net le site ddi  l'automobile cr par ses utilisateurs
Partagez | 
 

Problème de CSS

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Voir le profil de l'utilisateur http://yggdrasill-treet.forumgratuit.org/
avatar
{ Membre }
{ Membre }

Féminin Messages : 100



Bonsoir,

Refaisant mon forum de fond en comble, j'ai voulu également refaire le codage. J'avais un vieux code sur un ancien forum de test que j'aimais bien, et les deux forums étant en mêmes versions (phpBB2 subsilver), j'ai décidé de le réutiliser d'un à l'autre.

Seulement, si ç'a très bien fonctionné pour l'un, ça n'a absolument pas fonctionné pour l'autre : http://yggy-test.forumgratuit.org/
(c'est juste le forum test)

J'avais donc ceci à l'affichage sur le premier forum :
Spoiler:
 

C'était à peu près le résultat que je cherchais. J'ai donc installé mes codes CSS :

Code:
.categorie{
  width: 98%;
  margin: auto;
  margin-top: 10px;
  margin-bottom: 10px;
  background: #ffffff;
  border-top: 3px solid #;
  border-bottom: 1px solid #;
  border-right: 1px solid #;
  border-left: 1px solid #;
  box-shadow: 0px 0px 5px #;
  -moz-box-shadow: 0px 0px 5px #;
  -o-box-shadow: 0px 0px 5px #;
  -htm-box-shadow: 0px 0px 5px #;
  -webkit-box-shadow: 0px 0px 5px #;

border-radius: 10px 10px 10px 10px;
  -webkit-border-radius: 10px 10px 10px 10px;
  -moz-border-radius: 10px 10px 10px 10px;}

.forum{
  width: 98%;
  margin-left: auto;
  margin-right: auto;
  margin-top: 5px;
  margin-bottom: 5px;
  background: #ffffff;
  border: 1px dotted #;
  padding: 2px;
 border-radius: 10px 10px 10px 10px;
  -webkit-border-radius: 10px 10px 10px 10px;
  -moz-border-radius: 10px 10px 10px 10px;}

.forumlink{
  display: block;
  width: 450px;
  font-variant: small-caps;
  letter-spacing: 2px;
  padding-left: 20px;
  text-shadow: 1px 1px 0px #d0e8d5;
 border-radius: 10px 10px 10px 10px;
  -webkit-border-radius: 10px 10px 10px 10px;
  -moz-border-radius: 10px 10px 10px 10px;}

.forumlink a{
  font-size: 16px;
  border-bottom: 2px dotted #d0e8d5;
 border-radius: 10px 10px 10px 10px;
  -webkit-border-radius: 10px 10px 10px 10px;
  -moz-border-radius: 10px 10px 10px 10px;}

.description{
  display: block;
  width: 490px;
  margin: auto;
  font-size: 11px;
  text-align: justify;
  color: #000000;}

.illu{
  float: right;
  margin-left: 15px;
  margin-right: 15px;
  margin-bottom: 10px;
  border: 1px solid #;
  background: #ebf4e9;
  padding: 5px;
  -moz-border-radius: 5px 5px 5px 5px;
  -webkit-border-radius: 5px 5px 5px 5px;
  border-radius: 5px 5px 5px 5px;}

.stats_last{
  display: block;
  width: 160px;
  margin: auto;
  background: #ebf4e9;
  padding: 10px;
  border: 1px dotted #;
  border-radius: 10px 10px 10px 10px;
  -webkit-border-radius: 10px 10px 10px 10px;
  -moz-border-radius: 10px 10px 10px 10px;

-moz-box-shadow: 0px 0px 3px #91b38b;
  box-shadow: 0px 0px 3px #91b38b;
  -webkit-box-shadow: 0px 0px 3px #91b38b;}
.stats{ 
  display: block;
  text-align: center;
  font-size: 10px;
  color: #000000;
  border-bottom: 1px solid #;
  padding-bottom: 4px;
  margin-bottom: 4px;
  border-radius: 10px 10px 10px 10px;
  -webkit-border-radius: 10px 10px 10px 10px;
  -moz-border-radius: 10px 10px 10px 10px;
 
-moz-box-shadow: 0px 0px 3px #000000;
  box-shadow: 0px 0px 3px #000000;
  -webkit-box-shadow: 0px 0px 3px #000000;}

.last{
  display: block;
  text-align: center;
  font-size: 11px;}

.sous_forum{
  display: block;
  width: 98%;
  margin: auto;
  background: #ebf4e9;
  padding: 2px;
  text-align: center;
  border-radius: 10px 10px 10px 10px;
  -webkit-border-radius: 10px 10px 10px 10px;
  -moz-border-radius: 10px 10px 10px 10px;}

Et le template que je suppose aller avec (en tout cas, l'affichage du CSS n'était pas tant que le template n'était pas enregistré)

Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
  <tr>
      <td valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <span class="gensmall">{LAST_VISIT_DATE}<br />
        {CURRENT_TIME}<br />
        </span>
        <!-- END switch_user_logged_in -->
        <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
        <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
        <!-- END switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
  </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead -->

<div class="cate_titre">{catrow.tablehead.L_FORUM}</div>

<div class="categorie">

  <!-- END tablehead -->
  <!-- BEGIN cathead -->
 
  <!-- END cathead -->
  <!-- BEGIN forumrow -->
 
  <div class="forum">
   
<table><tr>
  <td><span class="forum_icone"><img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></span></td>
  <td style="vertical-align: top;"><span class="forumlink">
              <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
            </span>
  <span class="description">{catrow.forumrow.FORUM_DESC}</span></td>
  <td><span class="stats_last"><span class="stats">{catrow.forumrow.TOPICS} sujets ; {catrow.forumrow.POSTS} messages</span>
    <span class="last">{catrow.forumrow.LAST_POST}</span></span></td>
</tr></table>
   
    <span class="sous_forum">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span>
   
  </div>

  <!-- END forumrow -->
  <!-- BEGIN catfoot -->
 
  <!-- END catfoot -->
  <!-- BEGIN tablefoot -->
 
  </div>
 
<!-- END tablefoot --><!-- END catrow -->

Et c'est là que le bazar commençait. L'affichage du premier forum n'apparaissait pas du tout. J'avais des descriptions à la police de texte agrandie, une page déformée...

J'ai fini par arriver à ce qui apparaît sur le forum test, et mon souci, c'est que j'aimerais que la "décoration" des dernières statistiques soit centrée dans la colonne qui lui est réservée, et soit également placée à gauche du forum et non à droite...

Merci d'avance pour vos réponses !
MessageSujet: Problème de CSS   Sam 23 Mar 2013, 16:55
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
avatar
{ Spécialiste }
{ Spécialiste }

Féminin Messages : 3809



Bonsoir,

Tu t'es trompée de section il me semble Wink Pour tout problème de html ou de css il y a une section qui porte bien son nom --> Aide CSS & xHTML

Ici il s'agit juste d'une section d'avis, de conseils tout au plus, personne ne résoudra ton problème.

Merci de ta compréhension et à bientôt Smile


Allez les filles! Aidez-nous à vaincre les hommes! Faites remonter le compteur on compte sur vous! --> Hommes vs. Femmes
MessageSujet: Re: Problème de CSS   Sam 23 Mar 2013, 18:29
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://yggdrasill-treet.forumgratuit.org/
avatar
{ Membre }
{ Membre }

Féminin Messages : 100



Oups ! Effectivement.

Merci, je vais poster ça ailleurs. Désolée pour la bourde.
MessageSujet: Re: Problème de CSS   Sam 23 Mar 2013, 18:30
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
avatar
Psychopathe
Psychopathe

Féminin Messages : 3407



Hello !
Etant donné que tu as déjà posté ton sujet ailleurs, je vais archiver celui-ci (:
Merci Mzelle Machin pour l'indication


MessageSujet: Re: Problème de CSS   Dim 24 Mar 2013, 17:21
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: Problème de CSS   
Revenir en haut Aller en bas
 

Problème de CSS

Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

 Sujets similaires

-
» [Résolu] Problème avec psg tv
» Problème avec roll over qui "clignote"
» [/résolu] problème avec java à l'instalation :-/
» problème ps2
» Problème avec Java

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
CSSActif :: Corbeille :: Archives de CSSActif-

Partenaires Or


← Page précédente   ↑ Aller en haut Copyright © CSSActif 2009 - 2013 Tous droits réservés
Créer un forum | © phpBB | Forum gratuit d'entraide | Contact | Signaler un abus | Forum gratuit