Problème avec catégories. (RESOLU) Bouton_activeProblème avec catégories. (RESOLU) Bouton_hoverProblème avec catégories. (RESOLU) Fb-hoverProblème avec catégories. (RESOLU) Fb-active
C'est la fin du projet CSSActif, vous trouverez les explications ici : Fin de CSSActif, ouverture du forum. Le forum reste cependant ouvert à tous et ses ressources sont entièrement disponibles. Merci à tous !
Derniers sujets

Partagez
 

Problème avec catégories. (RESOLU)

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Voir le profil de l'utilisateur http://enjoy.forums-rpg.com
Shuffy ϟ
{ Membre actif }
{ Membre actif }

Féminin Messages : 628



Problème avec catégories. (RESOLU) Empty
Bonjour/bonsoir,
Je viens d'installer des catégories "en tableau" mais cela ne peut pas aller avec mes widgets. Vous avez rien compris ? J'ai prévu ! What a Face

Problème avec catégories. (RESOLU) Sans_t70

Ca va mieux ? En fait, j'aimerais que cela refasse un tableau avec les widgets (:. Par contre, pas de soucis, je sais que mon forum sera plus large que la moyenne, ce n'est pas un problème.
Je suis en version google chrome.

Voici les codes CSS :
Code:
/* MISE EN FORME DES CATEGORIES ET FORUMS */

.cate_titre
{
  clear: both;
  height: 100px;
  margin-top: 50px;
}
.catetitre_bloc
{
position: relative;
z-index: 1;
display: block;
width: 90%;
height: 20px;
margin-left: auto;
margin-right : auto;
background-color: #a8a8a8;
transform: rotate(5deg);
-moz-transform: rotate(5deg);
-o-transform: rotate(5deg);
-webkit-transform: rotate(5deg);
-htm-transform: rotate(5deg);
}
.catetitre_content
{
position: absolute;
z-index: 2;
display: block;
width: 950px;
margin-left: auto;
  margin-right: auto;
  margin-top: -40px;
text-align: center;
padding: 2px;
  border-bottom: 3px dotted #191817;
}
.catetitre
{
color: #454545;
font-family: arial;
font-size: 26px;
font-weight: bold;
text-transform: uppercase;
letter-spacing: 1px;
text-shadow: 1px 1px 0px #000000;
}

.forum_bloc
{
  width: 750px;
  margin-left: auto;
  margin-right: auto;
  margin-top: -30px;
}
.forum
{
float: left;
width: 325px;
height: 250px;
margin-left: 5px;
margin-right: 5px;
margin-bottom: 50px;
}
a.forumlink
{
  position: relative;
  z-index: 2;
  display: block;
  width: 100%;
  color: #454545;
  text-align: center;
font-family: arial;
font-size: 18px;
font-weight: bold;
text-transform: uppercase;
letter-spacing: 1px;
text-shadow: 1px 1px 0px #000000;
    transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}
a.forumlink:hover
{
  letter-spacing: 4px;
    transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}
.forum_contenu
{
  position: relative;
  z-index: 1;
  width: 98%;
  height: 90%;
  padding: 4px;
  margin-left: auto;
  margin-right: auto;
  margin-top: -8px;
  background-color: #d9d9d9;
  border-left: 1px dotted #191817;
  border-right: 1px dotted #191817;
  border-bottom: 1px dotted #191817;
  border-top: 5px solid #191817;
}
.description
{
  display: block;
  width: 400px;
  margin: auto;
  height: 100px;
  overflow: hidden;
  border: 2px solid #9c9c9c;
  box-shadow: 1px 1px 1px #191817;
  -moz-box-shadow: 1px 1px 1px #191817;
  -htm-box-shadow: 1px 1px 1px #191817;
  -webkit-box-shadow: 1px 1px 1px #191817;
  -o-box-shadow: 1px 1px 1px #191817;
}
.description_contenu
{
  position: absolute;
  display: block;
  width: 391px;
  height: 91px;
  overflow: auto;
  background-color: #191817;
  font-size: 10px;
  color: #9c9c9c;
  text-align: justify;
  padding: 5px;
  opacity: 0;
  -moz-opacity: 0;
  -khtml-opacity: 0;
  filter: alpha(opacity=0);
  transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}
.description_contenu:hover
{
  opacity: 0.8;
  -moz-opacity: 0.8;
  -khtml-opacity: 0.8;
  filter: alpha(opacity=80);
  transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}
.icone_stats
{
  width: 300px;
  margin: auto;
  margin-top: -30px;
}
.stats_lastpost
{
  display: block;
  width: 160px;
  height: 80px;
  margin-left: 10px;
  background-color: #c8c8c8;
  border: 1px solid #b5b5b5;
  padding: 5px;
  text-align: center;
}
.stats
{
  display: block;
  margin-bottom: 5px;
  border-bottom: 1px dotted #b5b5b5;
  padding-bottom: 5px;
  font-size: 10px;
  color: #8f8f8f;
}
.lastpost
{
  display: block;
  font-size: 11px;
}
.sforum
{
  position: relative;
  z-index: 3;
  display: block;
  height: 0;
    background: #191817;
  color: #b5b5b5;
  overflow: hidden;
    transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}
.ouverture_sousforum
{
  position: relative;
  z-index: 3;
  display: block;
  float: right;
  width: 120px;
  margin-right: 20px;
  background: #191817;
  color: #b5b5b5;
  font-size: 11px;
  text-align: center;
  padding: 4px;
  -webkit-border-bottom-right-radius: 10px;
-webkit-border-bottom-left-radius: 10px;
-moz-border-radius-bottomright: 10px;
-moz-border-radius-bottomleft: 10px;
border-bottom-right-radius: 10px;
border-bottom-left-radius: 10px;
}
.sous_forum:hover .sforum
{
  height: 50px;
  background: #191817;
  color: #b5b5b5;
  padding: 4px;
  overflow: auto;
    transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}
.sous_forum a
{
  color: #b5b5b5 !important;
  text-shadow: 1px 1px 0px #000000;
}
.sous_forum a:hover
{
  color: #ffffff !important;
}

Et le template index-box :
Code:
<tr>
      <td valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <span class="gensmall">{LAST_VISIT_DATE}<br />
        {CURRENT_TIME}<br />
        </span>
        <!-- END switch_user_logged_in -->
        <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
        <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
        <!-- END switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
  </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead -->

<div class="cate_titre"><span class="catetitre_bloc"></span>
  <span class="catetitre_content">{catrow.tablehead.L_FORUM}</span></div>

  <!-- END tablehead -->
  <!-- BEGIN cathead -->


  <!-- END cathead -->
  <!-- BEGIN forumrow -->
 

<div class="forum_bloc">
<div class="forum">
 
  <span class="forumlink">
  <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a>
  </span>
 
  <div class="forum_contenu">
    {catrow.forumrow.FORUM_DESC}<br />
   
    <div class="icone_stats"><table><tr><td><img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" class="icone" /></td>
      <td><span class="stats_lastpost">
        <span class="stats">{catrow.forumrow.TOPICS} sujets ; {catrow.forumrow.POSTS} messages</span>
        <span class="lastpost">{catrow.forumrow.LAST_POST}</span>
        </span></td>
      </tr></table></div>
   
  </div>
 
  <div class="sous_forum">
    <span class="sforum">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span>
    <span class="ouverture_sousforum">Voir les sous-forum</span>
  </div>
 
</div>
</div>


  <!-- END forumrow -->
  <!-- BEGIN catfoot -->

  <!-- END catfoot -->
  <!-- BEGIN tablefoot -->

<!-- END tablefoot --><!-- END catrow -->

Les widgets, eux, sont ceux de bases de forumactif.

Merci à vous (: Problème avec catégories. (RESOLU) 577704309


Dernière édition par Shuffy ϟ le Jeu 09 Aoû 2012, 07:54, édité 1 fois
MessageSujet: Problème avec catégories. (RESOLU)   Problème avec catégories. (RESOLU) EmptyDim 05 Aoû 2012, 13:24
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://enjoy.forums-rpg.com
Shuffy ϟ
{ Membre actif }
{ Membre actif }

Féminin Messages : 628



Problème avec catégories. (RESOLU) Empty
Personne ? Problème avec catégories. (RESOLU) 825433
MessageSujet: Re: Problème avec catégories. (RESOLU)   Problème avec catégories. (RESOLU) EmptyLun 06 Aoû 2012, 11:20
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Psycho
Psychopathe
Psychopathe

Féminin Messages : 3407



Problème avec catégories. (RESOLU) Empty
Hello Shuffy ϟ !
Je cite simplement le règlement de CSSActif :
"Remonter un sujet, le fameux «Up», est interdit sur CSSActif. L'équipe fait déjà le maximum pour répondre à votre demande le plus rapidement possible et la remontra elle-même en cas de besoin. Il est par conséquent inutile de signaler votre impatience."
J'imagine que tu es capable de comprendre toute seule ^^
Merci de faire attention la prochaine fois Problème avec catégories. (RESOLU) 926145


Problème avec catégories. (RESOLU) Signature_staff
MessageSujet: Re: Problème avec catégories. (RESOLU)   Problème avec catégories. (RESOLU) EmptyLun 06 Aoû 2012, 12:42
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://enjoy.forums-rpg.com
Shuffy ϟ
{ Membre actif }
{ Membre actif }

Féminin Messages : 628



Problème avec catégories. (RESOLU) Empty
Pardon :/
MessageSujet: Re: Problème avec catégories. (RESOLU)   Problème avec catégories. (RESOLU) EmptyLun 06 Aoû 2012, 13:22
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://enaevolare.fr
'Christa
Lostmindy
Lostmindy

Féminin Messages : 2853



Problème avec catégories. (RESOLU) Empty
Bonjour, pourrait-on avoir le lien de ton forum de test ? J'ai essayé avec l'adresse de ton aperçu et ça m'a redirigée sur une autre adresse (http://discoverbreeding.naturalforum.net/) sur laquelle il n'y a rien d'anormal.

Accessoirement, ton template index_box est incomplet '_'


Problème avec catégories. (RESOLU) Signature_staff
Ne me vouvoyez pas, merci (même si vous avez 15 ans de moins que moi, j'veux pas le savoir)
MessageSujet: Re: Problème avec catégories. (RESOLU)   Problème avec catégories. (RESOLU) EmptyMar 07 Aoû 2012, 18:44
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://enjoy.forums-rpg.com
Shuffy ϟ
{ Membre actif }
{ Membre actif }

Féminin Messages : 628



Problème avec catégories. (RESOLU) Empty
Bonjour,
Le lien du forum est bien http://discoverbreeding.naturalforum.net/, seulement le template n'était pas validé. ^^
Mon problème, c'est que j'aimerai avoir les widgets de FA en tableau avec les catégories composites, comme ça par exemple :
Problème avec catégories. (RESOLU) Clive_10

J'aau aussi fait des modifications :
CSS :
Code:
/* MISE EN FORME DES CATEGORIES ET FORUMS */
.cate_titre
{
  clear: both;
  height: 50px;
  margin-top: 50px;
}

.catetitre_content
{
position: absolute;
z-index: 2;
display: block;
width: 750px;
margin-left: auto;
  margin-right: auto;
text-align: center;
padding: 2px;
}
.catetitre
{
color: #454545;
font-family: arial;
font-size: 20px;
font-weight: bold;
text-transform: uppercase;
letter-spacing: 1px;
text-shadow: 1px 1px 0px #000000;
}

.forum_bloc
{
  width: 750px;
  margin-left: auto;
  margin-right: auto;
  margin-top: -30px;
}
.forum
{
float: left;
width: 325px;
height: 170px;
margin-left: 5px;
margin-right: 5px;
margin-bottom: 50px;
}
a.forumlink
{
  position: relative;
  z-index: 2;
  display: block;
  width: 100%;
  color: #454545;
  text-align: center;
font-family: arial;
font-size: 18px;
font-weight: bold;
text-transform: uppercase;
letter-spacing: 1px;
text-shadow: 1px 1px 0px #000000;
    transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}
a.forumlink:hover
{
  letter-spacing: 4px;
    transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}
.forum_contenu
{
  position: relative;
  z-index: 1;
  width: 98%;
  height: 90%;
  padding: 4px;
  margin-left: auto;
  margin-right: auto;
  margin-top: -8px;
  line-height:11px;
  padding: 4px;
  font-size:11px;
  text-align:justify;
  background-color: #d9d9d9;
  border-left: 1px dotted #191817;
  border-right: 1px dotted #191817;
  border-bottom: 1px dotted #191817;
  border-top: 5px solid #191817;
}

.icone_stats
{
  width: 300px;
  margin: auto;
  margin-top: -30px;
}
.stats_lastpost
{
  display: block;
  width: 160px;
  height: 50px;
  margin-left: 10px;
  background-color: #c8c8c8;
  border: 1px solid #b5b5b5;
  padding: 5px;
  text-align: center;
}
.stats
{
  display: block;
  margin-bottom: 5px;
  border-bottom: 1px dotted #b5b5b5;
  padding-bottom: 5px;
  font-size: 10px;
  color: #8f8f8f;
}
.lastpost
{
  display: block;
  font-size: 11px;
}
.sforum
{
  position: relative;
  z-index: 3;
  display: block;
  height: 0;
    background: #191817;
  color: #b5b5b5;
  overflow: hidden;
    transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}
.ouverture_sousforum
{
  position: relative;
  z-index: 3;
  display: block;
  float: right;
  width: 150px;
  margin-right: 20px;
  background: #191817;
  color: #b5b5b5;
  font-size: 11px;
  text-align: center;
  padding: 4px;
  -webkit-border-bottom-right-radius: 10px;
-webkit-border-bottom-left-radius: 10px;
-moz-border-radius-bottomright: 10px;
-moz-border-radius-bottomleft: 10px;
border-bottom-right-radius: 10px;
border-bottom-left-radius: 10px;
}
.sous_forum:hover .sforum
{
  height: 20px;
  background: #191817;
  color: #b5b5b5;
  padding: 4px;
  overflow: auto;
    transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}
.sous_forum a
{
  color: #b5b5b5 !important;
  text-shadow: 1px 1px 0px #000000;
}
.sous_forum a:hover
{
  color: #ffffff !important;
}

Template :
Code:
  <tr>
      <td valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <span class="gensmall">{LAST_VISIT_DATE}<br />
        {CURRENT_TIME}<br />
        </span>
        <!-- END switch_user_logged_in -->
        <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
        <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
        <!-- END switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
  </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead -->

<div class="cate_titre"><span class="catetitre_bloc"></span>
  <span class="catetitre_content">{catrow.tablehead.L_FORUM}</span></div>

  <!-- END tablehead -->
  <!-- BEGIN cathead -->


  <!-- END cathead -->
  <!-- BEGIN forumrow -->
 

<div class="forum_bloc">
<div class="forum">
 
  <span class="forumlink">
  <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a>
  </span>
 
  <div class="forum_contenu">
    {catrow.forumrow.FORUM_DESC}<br /><br>
   
    <div class="icone_stats"><table><tr><td><img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" class="icone" /></td>
      <td><span class="stats_lastpost">
        <span class="stats">{catrow.forumrow.TOPICS} sujets ; {catrow.forumrow.POSTS} messages</span>
        <span class="lastpost">{catrow.forumrow.LAST_POST}</span>
        </span></td>
      </tr></table></div>
   
  </div>
 
  <div class="sous_forum">
    <span class="sforum">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span>
    <span class="ouverture_sousforum">Afficher les sous-forum</span>
  </div>
 
</div>
</div>


  <!-- END forumrow -->
  <!-- BEGIN catfoot -->

  <!-- END catfoot -->
  <!-- BEGIN tablefoot -->

<!-- END tablefoot --><!-- END catrow -->

Merci ! (:
MessageSujet: Re: Problème avec catégories. (RESOLU)   Problème avec catégories. (RESOLU) EmptyJeu 09 Aoû 2012, 07:41
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://enjoy.forums-rpg.com
Shuffy ϟ
{ Membre actif }
{ Membre actif }

Féminin Messages : 628



Problème avec catégories. (RESOLU) Empty
J'ai trouvé ! o/
Il suffit d'enlever cette partie dans le template :
Code:
 <tr>
      <td valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <span class="gensmall">{LAST_VISIT_DATE}<br />
        {CURRENT_TIME}<br />
        </span>
        <!-- END switch_user_logged_in -->
        <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
        <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
        <!-- END switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
  </tr>
</table>

Merci !
MessageSujet: Re: Problème avec catégories. (RESOLU)   Problème avec catégories. (RESOLU) EmptyJeu 09 Aoû 2012, 07:53
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Psycho
Psychopathe
Psychopathe

Féminin Messages : 3407



Problème avec catégories. (RESOLU) Empty
Yop'
Puisque le problème est apparemment résolu, je classe (:
Merci de l'avoir signalé Problème avec catégories. (RESOLU) 926145
Et merci d'avoir partagé la solution que tu as trouvé !
NB à l'attention des autres membres : je n'ai pas dis pour autant qu'elle était correcte Wink


Problème avec catégories. (RESOLU) Signature_staff
MessageSujet: Re: Problème avec catégories. (RESOLU)   Problème avec catégories. (RESOLU) EmptyJeu 09 Aoû 2012, 15:57
Revenir en haut Aller en bas
Contenu sponsorisé




Problème avec catégories. (RESOLU) Empty
MessageSujet: Re: Problème avec catégories. (RESOLU)   Problème avec catégories. (RESOLU) Empty
Revenir en haut Aller en bas
 

Problème avec catégories. (RESOLU)

Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
CSSActif :: De la théorie à la pratique :: Aide CSS & xHTML :: Problèmes résolus-

Partenaires Or


← Page précédente   ↑ Aller en haut Copyright © CSSActif 2009 - 2013 Tous droits réservés
Créer un forum | © phpBB | Forum gratuit d'entraide | Contact | Signaler un abus | Forum gratuit